AddFace Method


Tessellated Shape Builder Add Face Method

Adds a face to the currently open connected face set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AddFace(
	TessellatedFace face
)

Parameters

face TessellatedFace
Face to add. The 'face' parameter can be added only once, as its boundary loops will be cleared while adding and 'face' will become unusable.
Exceptions
Exception Condition
ArgumentException The 'face' does not have enough loops and/or vertices to be valid.
ArgumentNullException A non-optional argument was null
InvalidOperationException A face set is closed and faces cannot be added to it.
See Also