Outputs the formula parameter ids defined in the RebarShape family which are associated with hook length and hook tangent length parameters.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- startHookLengthPrameters
- Type: System.Collections.GenericISetElementId%
The formula parameter ids defined in the RebarShape family which are associated with start hook length parameters.
- startHookTangentLengthParameters
- Type: System.Collections.GenericISetElementId%
The formula parameter ids defined in the RebarShape family which are associated with start hook tangent length parameters.
- endHookLengthParameters
- Type: System.Collections.GenericISetElementId%
The formula parameter ids defined in the RebarShape family which are associated with end hook length parameters.
- endHookTangentLengthParameters
- Type: System.Collections.GenericISetElementId%
The formula parameter ids defined in the RebarShape family which are associated with end hook tangent length parameters.
Remarks
Will throw an exception if the hook length override is not enabled.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsInvalidOperationException | The ability to override hook lengths is not enabled for this rebar instance. Use enableHookLengthOverride(true) to enable it. |