GetOverridableHookParameters Method


Rebar Get Overridable Hook Parameters Method

Outputs the formula parameter ids defined in the RebarShape family which are associated with hook length and hook tangent length parameters.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void GetOverridableHookParameters(
	out ISet<ElementId> startHookLengthPrameters,
	out ISet<ElementId> startHookTangentLengthParameters,
	out ISet<ElementId> endHookLengthParameters,
	out ISet<ElementId> endHookTangentLengthParameters
)

Parameters

startHookLengthPrameters ISet ElementId
The formula parameter ids defined in the RebarShape family which are associated with start hook length parameters.
startHookTangentLengthParameters ISet ElementId
The formula parameter ids defined in the RebarShape family which are associated with start hook tangent length parameters.
endHookLengthParameters ISet ElementId
The formula parameter ids defined in the RebarShape family which are associated with end hook length parameters.
endHookTangentLengthParameters ISet ElementId
The formula parameter ids defined in the RebarShape family which are associated with end hook tangent length parameters.
Exceptions
Exception Condition
InvalidOperationException The ability to override hook lengths is not enabled for this rebar instance. Use enableHookLengthOverride(true) to enable it.
Remarks
Will throw an exception if the hook length override is not enabled.
See Also