IsValidPersistentIdsMap Method


A validator function that makes sure that all BRepBuilderGeometryIds in the input map can be found in this BRepBuilder object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2016

Syntax

C#
public bool IsValidPersistentIdsMap(
	BRepBuilderPersistentIds brepPersistentIds
)
Visual Basic
Public Function IsValidPersistentIdsMap ( _
	brepPersistentIds As BRepBuilderPersistentIds _
) As Boolean
Visual C++
public:
bool IsValidPersistentIdsMap(
	BRepBuilderPersistentIds^ brepPersistentIds
)

Parameters

brepPersistentIds
Type: Autodesk.Revit.DBBRepBuilderPersistentIds
The map that associates ExternalGeometryIds to BRepBuilderGeometryIds.

Return Value

True if all BRepBuilderGeometryIds in the input map can be found in this BRepBuilder object, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also