IsValidPersistentIdsMap Method


BRep Builder Is Valid Persistent Ids Map Method

A validator function that makes sure that all BRepBuilderGeometryIds in the input map can be found in this BRepBuilder object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsValidPersistentIdsMap(
	BRepBuilderPersistentIds brepPersistentIds
)

Parameters

brepPersistentIds BRepBuilderPersistentIds
The map that associates ExternalGeometryIds to BRepBuilderGeometryIds.

Return Value

Boolean
True if all BRepBuilderGeometryIds in the input map can be found in this BRepBuilder object, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also