AngleOnPlaneTo Method


Returns the angle between this vector and the specified vector projected to the specified plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double AngleOnPlaneTo(
	XYZ right,
	XYZ normal
)
Visual Basic
Public Function AngleOnPlaneTo ( _
	right As XYZ, _
	normal As XYZ _
) As Double
Visual C++
public:
double AngleOnPlaneTo(
	XYZ^ right, 
	XYZ^ normal
)

Parameters

right
Type: Autodesk.Revit.DBXYZ
The specified vector.
normal
Type: Autodesk.Revit.DBXYZ
The normal vector that defines the plane.

Return Value

The real number between 0 and 2*PI equal to the projected angle between the two vectors.

Remarks

The angle is projected onto the plane orthogonal to the specified normal vector, counterclockwise with the normal pointing upwards.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException Thrown when right or normal is a null reference (Nothing in Visual Basic).

See Also