XYZ Angle |
Returns the angle between this vector and the specified vector projected to the specified plane.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
Return Value
DoubleThe real number between 0 and 2*PI equal to the projected angle between the two vectors.

Exception | Condition |
---|---|
ArgumentNullException | Thrown when right or normal is . |

The angle is projected onto the plane orthogonal to the specified normal vector, counterclockwise with the normal pointing upwards.