Returns the angle between this vector and the specified vector.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- source
- Type: Autodesk.Revit.DBXYZ
The specified vector.
Return Value
The real number between 0 and PI equal to the angle between the two vectors in radians..Remarks
The angle between the two vectors is measured in the plane spanned by them.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | Thrown when source is a null reference (Nothing in Visual Basic). |