SetMapOfInLinePartTypes Method


Set the mapping of fabrication part types for in-line parts for the service and palette to change to.

Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018.2

Syntax

C#
public void SetMapOfInLinePartTypes(
	IDictionary<ElementId, ElementId> fabricationPartTypes
)
Visual Basic
Public Sub SetMapOfInLinePartTypes ( _
	fabricationPartTypes As IDictionary(Of ElementId, ElementId) _
)
Visual C++
public:
void SetMapOfInLinePartTypes(
	IDictionary<ElementId^, ElementId^>^ fabricationPartTypes
)

Parameters

fabricationPartTypes
Type: System.Collections.GenericIDictionaryElementId, ElementId
The map containing the original fabrication part type to the fabrication part type to change to.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also