SetMapOfInLinePartTypes Method


Fabrication Network Change Service Set Map Of In Line Part Types Method

Set the mapping of fabrication part types for in-line parts for the service and palette to change to.

Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetMapOfInLinePartTypes(
	IDictionary<ElementId, ElementId> fabricationPartTypes
)

Parameters

fabricationPartTypes IDictionary ElementId , ElementId
The map containing the original fabrication part type to the fabrication part type to change to.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also