Returns list of the failure resolution types attempted for the failure in the current transaction.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- failure
- Type: Autodesk.Revit.DBFailureMessageAccessor
The failure.
Return Value
The list of the types of failure resolutions attempted for the failure.Remarks
In some cases attempt to resolve a failure has no impact or failure gets reposted during next round of the end of transaction checks after being resolved. Knowing if any failure resolutions were attempted for the failure allows failures processor to prevent infinite loop.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | failure has not been properly initialized. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing). |