Failures |
Returns list of the failure resolution types attempted for the failure in the current transaction.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public IList<FailureResolutionType> GetAttemptedResolutionTypes(
FailureMessageAccessor failure
)
Parameters
- failure FailureMessageAccessor
- The failure.
Return Value
IList FailureResolutionTypeThe list of the types of failure resolutions attempted for the failure.

Exception | Condition |
---|---|
ArgumentException | failure has not been properly initialized. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing). |

In some cases attempt to resolve a failure has no impact or failure gets reposted during next round of the end of transaction checks after being resolved. Knowing if any failure resolutions were attempted for the failure allows failures processor to prevent infinite loop.