PropagateToViews Method


Propagates the extents applied to this datum in the view to the specified parallel views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2016

Syntax

C#
public void PropagateToViews(
	View view,
	ISet<ElementId> parallelViews
)
Visual Basic
Public Sub PropagateToViews ( _
	view As View, _
	parallelViews As ISet(Of ElementId) _
)
Visual C++
public:
void PropagateToViews(
	View^ view, 
	ISet<ElementId^>^ parallelViews
)

Parameters

view
Type: Autodesk.Revit.DBView
The view on which the DatumPlane shows.
parallelViews
Type: System.Collections.GenericISetElementId
The ids of the specified parallel views.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The datum plane cannot be visible in the view. -or- One ElementId in parallelViews is not valid for extent propagation.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also