PropagateToViews Method


Datum Plane Propagate To Views Method

Propagates the extents applied to this datum in the view to the specified parallel views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void PropagateToViews(
	View view,
	ISet<ElementId> parallelViews
)

Parameters

view View
The view on which the DatumPlane shows.
parallelViews ISet ElementId
The ids of the specified parallel views.
Exceptions
Exception Condition
ArgumentException The datum plane cannot be visible in the view. -or- One ElementId in parallelViews is not valid for extent propagation.
ArgumentNullException A non-optional argument was null
See Also