Creates divided parts out of parts.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document containing the parts.
- elementIdsToDivide
- Type: System.Collections.GenericICollectionElementId
The elements that will be divided.
- intersectingReferenceIds
- Type: System.Collections.GenericICollectionElementId
Intersecting references that will divide the elements.
- curveArray
- Type: System.Collections.GenericIListCurve
Array of curves that will divide the elements.
- sketchPlaneId
- Type: Autodesk.Revit.DBElementId
SketchPlane id for the curves that divide the elements.
Return Value
The newly created PartMaker. a null reference (Nothing in Visual Basic) if no parts are divided.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | One or more element ids was not permitted for dividing parts. Elements should be parts that are not yet divided and maximum distance from an original has not yet been reached. -or- One or more element ids was not permitted as intersecting references. Intersecting references should be levels, grids, or reference planes. -or- The element id should refer to a valid SketchPlane. -or- The input curveArray contains at least one helical curve and is not supported for this operation. -or- The input curveArray contains at least one NULL pointer and is not supported for this operation. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). |
Autodesk.Revit.ExceptionsModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.ExceptionsModificationOutsideTransactionException | The document has no open transaction. |