Scales the basis vectors and the origin of this transformation and returns the result.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- scale
- Type: SystemDouble
The scale value.
Return Value
The transformation equal to the composition of the two transformations.Remarks
The resulting transformation is equivalent to the application of this transformation and then the uniform scale, in this order.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | Thrown when the specified value is an infinite number. |