Transform Scale |
Scales the basis vectors and the origin of this transformation and returns the result.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- scale Double
- The scale value.
Return Value
TransformThe transformation equal to the composition of the two transformations.

Exception | Condition |
---|---|
ArgumentException | Thrown when the specified value is an infinite number. |

The resulting transformation is equivalent to the application of this transformation and then the uniform scale, in this order.