FilterElementIdRule Class


A filter rule that operates on ElementId values in a Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public class FilterElementIdRule : FilterNumericValueRule
Visual Basic
Public Class FilterElementIdRule _
	Inherits FilterNumericValueRule
Visual C++
public ref class FilterElementIdRule : public FilterNumericValueRule

Remarks

When GetRuleParameter returns a parameter that UsesLevelFiltering(Document, ElementId), then the comparisons will first compare the values of the levels' elevations, then compare the levels' names, and finally the levels' element ids to rank and sort the levels.

Inheritance Hierarchy

SystemObject
  Autodesk.Revit.DBFilterRule
    Autodesk.Revit.DBFilterValueRule
      Autodesk.Revit.DBFilterNumericValueRule
        Autodesk.Revit.DBFilterElementIdRule

See Also