FilterElementIdRule Class


Filter Element Id Rule Class

A filter rule that operates on ElementId values in a Revit project.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FilterElementIdRule : FilterNumericValueRule

The FilterElementIdRule type exposes the following members.

Constructors
Name Description
Public method FilterElementIdRule Constructs an instance of FilterElementIdRule.
Top
Properties
Name Description
Public property RuleValue The user-supplied value against which values from a Revit document will be tested.
Top
Methods
Name Description
Public method Static member UsesLevelFiltering This function checks if a parameter uses level filtering.
Top
Remarks
When GetRuleParameter returns a parameter that UsesLevelFiltering(Document, ElementId) , then the comparisons will first compare the values of the levels' elevations, then compare the levels' names, and finally the levels' element ids to rank and sort the levels.
See Also