FilterElementIdRule Class


Filter Element Id Rule Class

A filter rule that operates on ElementId values in a Revit project.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FilterElementIdRule : FilterNumericValueRule

The FilterElementIdRule type exposes the following members.

Constructors
Name Description
Public method FilterElementIdRule Constructs an instance of FilterElementIdRule.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from FilterRule )
Public property RuleValue The user-supplied value against which values from a Revit document will be tested.
Top
Methods
Name Description
Public method Dispose
(Inherited from FilterRule )
Public method ElementPasses Derived classes override this method to implement the test that determines whether the given element passes this rule or not.
(Inherited from FilterRule )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetEvaluator Gets the evaluator that implements the test for this rule.
(Inherited from FilterNumericValueRule )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetRuleParameter Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter.
(Inherited from FilterRule )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method SetEvaluator Sets the evaluator that implements the test for this rule.
(Inherited from FilterNumericValueRule )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Public method Static member UsesLevelFiltering This function checks if a parameter uses level filtering.
Top
Remarks
When GetRuleParameter returns a parameter that UsesLevelFiltering(Document, ElementId) , then the comparisons will first compare the values of the levels' elevations, then compare the levels' names, and finally the levels' element ids to rank and sort the levels.
See Also