Sets the ids of the base levels of the stairs upon which this railing is placed.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- levelIds
- Type: System.Collections.GenericISetElementId
The ids of levels the railing is placed on. If input level id set is empty, railings will placed on all levels of the hosting stairs.
Remarks
The method is valid only for railings hosted by stairs in MultistoryStairs. The input level ids have to be a subset of level ids of the railing stairs. See MultistoryStairs for information about the placement levels that may be passed as input.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | All of the level ids in levelIds must be placement levels of stairs. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | The railing is not hosted by stairs in MultistoryStairs. |