IsValidFaceId Method


A validator function that checks whether the face id corresponds to a face previously added to this BRepBuilder object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2016

Syntax

C#
public bool IsValidFaceId(
	BRepBuilderGeometryId faceId
)
Visual Basic
Public Function IsValidFaceId ( _
	faceId As BRepBuilderGeometryId _
) As Boolean
Visual C++
public:
bool IsValidFaceId(
	BRepBuilderGeometryId^ faceId
)

Parameters

faceId
Type: Autodesk.Revit.DBBRepBuilderGeometryId
Face id to be validated.

Return Value

True if faceId corresponds to a face previously added to this BRepBuilder, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also