Returns path information identifying where Revit searches for content.
Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Return Value
The map of library paths.Remarks
The map that is returned contains a key that is purpose of the path, such as Material Libraries and the value in the map is the fully qualified path that is used for that search path.
Examples

string strLibPaths = "";
foreach (String path in application.GetLibraryPaths().Values)
{
strLibPaths += path + "\n";
}

Dim strLibPaths As String = ""
For Each path As [String] In application.GetLibraryPaths().Values
strLibPaths += path & vbLf
Next