GetLibraryPaths Method


Application Get Library Paths Method

Returns path information identifying where Revit searches for content.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IDictionary<string, string> GetLibraryPaths()

Return Value

IDictionary String , String
The map of library paths.
Remarks
The map that is returned contains a key that is purpose of the path, such as Material Libraries and the value in the map is the fully qualified path that is used for that search path.
Example
string strLibPaths = "";
foreach (String path in application.GetLibraryPaths().Values)
{
    strLibPaths += path + "\n";
}
See Also