Determines whether the region is a simple region in this CompoundStructure.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- regionId
- Type: SystemInt32
The id of a region in this vertically compound structure.
Return Value
True if the region is simple, false otherwise.Remarks
A region is simple if it rectangular and spans the height of the wall.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | It is not a valid region id. |
Autodesk.Revit.ExceptionsInvalidOperationException | This operation is valid only for vertically compound structures. |