IsSimpleRegion Method


Compound Structure Is Simple Region Method

Determines whether the region is a simple region in this CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsSimpleRegion(
	int regionId
)

Parameters

regionId Int32
The id of a region in this vertically compound structure.

Return Value

Boolean
True if the region is simple, false otherwise.
Exceptions
Exception Condition
ArgumentException It is not a valid region id.
InvalidOperationException This operation is valid only for vertically compound structures.
Remarks
A region is simple if it rectangular and spans the height of the wall.
See Also