SetWorldTransform Method


Sets the world transformation that will be applied to geometry during rendering.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public static void SetWorldTransform(
	Transform trf
)
Visual Basic
Public Shared Sub SetWorldTransform ( _
	trf As Transform _
)
Visual C++
public:
static void SetWorldTransform(
	Transform^ trf
)

Parameters

trf
Type: Autodesk.Revit.DBTransform
The transformation matrix.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException This DrawContext is not available because Revit is not currently rendering. In general, this DrawContext must be used in the scope of the RenderScene() callback of IDirectContext3DServer.

See Also