SetWorldTransform Method


Draw Context Set World Transform Method

Sets the world transformation that will be applied to geometry during rendering.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void SetWorldTransform(
	Transform trf
)

Parameters

trf Transform
The transformation matrix.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
InvalidOperationException This DrawContext is not available because Revit is not currently rendering. In general, this DrawContext must be used in the scope of the RenderScene() callback of IDirectContext3DServer.
See Also