Adds a reference curve to the DirectShape.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- refCurve
- Type: Autodesk.Revit.DBCurve
The geometry of the new reference curve. First case: The input curve's bounds are set. The resulting reference curve that is added to the DirectShape will be displayed with those bounds. Note that the specified bounds must not be degenerate. Second case: The input curve is unbounded. Reasonable bounds are therefore automatically calculated and applied to the input curve. The automatic bounds are based on the host direct shape's geometry. Note that only lines and splines may be unbounded. You must specify valid bounds for all other curve types.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | refCurve cannot be used for creating a reference curve. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |