Direct |
Adds a reference curve to the DirectShape.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- refCurve Curve
- The geometry of the new reference curve.

Exception | Condition |
---|---|
ArgumentException | refCurve cannot be used for creating a reference curve. |
ArgumentNullException | A non-optional argument was null |

There are two cases to consider:
- The input curve's bounds are set. The resulting reference curve that is added to the DirectShape will be displayed with those bounds. Note that the specified bounds must not be degenerate. Permitted curve types are those for which [!:Autodesk::Revit::DB::DirectShape::isValidReferenceCurve] returns true.
- The input curve is unbounded. Reasonable bounds are automatically calculated and applied to the input curve. The automatic bounds are based on the host DirectShape's geometry.
Note that only lines and splines may be unbounded. You must specify valid bounds for all other curve types.