CanDefineRevitGeometry Method


Tests whether the supplied Frame object may be used to define a Revit curve or surface. In order to satisfy the requirements the Frame must be orthonormal and its origin is expected to lie within the Revit design limits IsWithinLengthLimits(XYZ).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public static bool CanDefineRevitGeometry(
	Frame frameOfReference
)
Visual Basic
Public Shared Function CanDefineRevitGeometry ( _
	frameOfReference As Frame _
) As Boolean
Visual C++
public:
static bool CanDefineRevitGeometry(
	Frame^ frameOfReference
)

Parameters

frameOfReference
Type: Autodesk.Revit.DBFrame
Frame to be validated.

Return Value

True if this Frame may be used as a local frame of reference, false otherwise.

Remarks

Certain Revit curve and surface types are defined using a local frame of reference.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also