Frame Can |
Tests whether the supplied Frame object may be used to define a Revit curve or surface. In order to satisfy the requirements the Frame must be orthonormal and its origin is expected to lie within the Revit design limits IsWithinLengthLimits(XYZ) .
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- frameOfReference Frame
- Frame to be validated.
Return Value
BooleanTrue if this Frame may be used as a local frame of reference, false otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

Certain Revit curve and surface types are defined using a local frame of reference.