Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing a given filter rule.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- filterRule
- Type: Autodesk.Revit.DBFilterRule
The rule applied to test if the element passes this filter.
- inverted
- Type: SystemBoolean
True if the filter should match all elements which do not pass the filter rule.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |