ElementParameterFilter Constructor (FilterRule, Boolean)


Element Parameter Filter(Filter Rule, Boolean) Constructor

Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing a given filter rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementParameterFilter(
	FilterRule filterRule,
	bool inverted
)

Parameters

filterRule FilterRule
The rule applied to test if the element passes this filter.
inverted Boolean
True if the filter should match all elements which do not pass the filter rule.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also