SetProjectionLinePatternId Method


Sets the ElementId of the projection surface line pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public OverrideGraphicSettings SetProjectionLinePatternId(
	ElementId linePatternId
)
Visual Basic
Public Function SetProjectionLinePatternId ( _
	linePatternId As ElementId _
) As OverrideGraphicSettings
Visual C++
public:
OverrideGraphicSettings^ SetProjectionLinePatternId(
	ElementId^ linePatternId
)

Parameters

linePatternId
Type: Autodesk.Revit.DBElementId
ElementId of the projection surface line pattern for the override. InvalidElementId means no override is set.

Return Value

Reference to the changed object.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also