SetProjectionLinePatternId Method


Override Graphic Settings Set Projection Line Pattern Id Method

Sets the ElementId of the projection surface line pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public OverrideGraphicSettings SetProjectionLinePatternId(
	ElementId linePatternId
)

Parameters

linePatternId ElementId
ElementId of the projection surface line pattern for the override. InvalidElementId means no override is set.

Return Value

OverrideGraphicSettings
Reference to the changed object.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also