Constructs a ReferenceIntersector which is set to return intersections from any of a set of target elements.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- targetElementIds
- Type: System.Collections.GenericICollectionElementId
The target element ids.
- targetType
- Type: Autodesk.Revit.DBFindReferenceTarget
The target type of references to return.
- view3d
- Type: Autodesk.Revit.DBView3D
The view in which to find references.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | Returns true if the view is not a view template. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |