ReferenceIntersector Constructor (ICollection(ElementId), FindReferenceTarget, View3D)


Reference Intersector(ICollection Element Id , Find Reference Target, View 3D) Constructor

Constructs a ReferenceIntersector which is set to return intersections from any of a set of target elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ReferenceIntersector(
	ICollection<ElementId> targetElementIds,
	FindReferenceTarget targetType,
	View3D view3d
)

Parameters

targetElementIds ICollection ElementId
The target element ids.
targetType FindReferenceTarget
The target type of references to return.
view3d View3D
The view in which to find references.
Exceptions
Exception Condition
ArgumentException Returns true if the view is not a view template.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also