CreateProjectLevelGUID Method


Creates a GUID from Revit project for given GUIDType.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public static string CreateProjectLevelGUID(
	Document document,
	IFCProjectLevelGUIDType guidType
)
Visual Basic
Public Shared Function CreateProjectLevelGUID ( _
	document As Document, _
	guidType As IFCProjectLevelGUIDType _
) As String
Visual C++
public:
static String^ CreateProjectLevelGUID(
	Document^ document, 
	IFCProjectLevelGUIDType guidType
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document.
guidType
Type: Autodesk.Revit.DB.IFCIFCProjectLevelGUIDType
The GUID type.

Return Value

The guid string.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also