Exporter |
Creates a GUID from Revit project for given GUIDType.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)

public static string CreateProjectLevelGUID(
Document document,
IFCProjectLevelGUIDType guidType
)
Parameters
- document Document
- The document.
- guidType IFCProjectLevelGUIDType
- The GUID type.
Return Value
StringThe guid string.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |