SetProjectionType Method


Sets the projection type of the CurveElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public static void SetProjectionType(
	CurveElement curveElem,
	CurveProjectionType value
)
Visual Basic
Public Shared Sub SetProjectionType ( _
	curveElem As CurveElement, _
	value As CurveProjectionType _
)
Visual C++
public:
static void SetProjectionType(
	CurveElement^ curveElem, 
	CurveProjectionType value
)

Parameters

curveElem
Type: Autodesk.Revit.DBCurveElement
The CurveElement.
value
Type: Autodesk.Revit.DBCurveProjectionType
The input projection type.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The input CurveElement is not a CurveByPoints.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also