Curve |
Sets the projection type of the CurveElement.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static void SetProjectionType(
CurveElement curveElem,
CurveProjectionType value
)
Parameters
- curveElem CurveElement
- The CurveElement.
- value CurveProjectionType
- The input projection type.

Exception | Condition |
---|---|
ArgumentException | The input CurveElement is not a CurveByPoints. |
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |