Create a new Form element by thickening a single-surface form, and add it into the Autodesk Revit family document.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- isSolid
- Type: SystemBoolean
Indicates if the Form is Solid or Void.
- singleSurfaceForm
- Type: Autodesk.Revit.DBForm
The single-surface form element. It can have one top/bottom face or one side face.
- thickenDir
- Type: Autodesk.Revit.DBXYZ
The offset of capped solid.