Family |
Create a new Form element by thickening a single-surface form, and add it into the Autodesk Revit family document.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public Form NewFormByThickenSingleSurface(
bool isSolid,
Form singleSurfaceForm,
XYZ thickenDir
)
Parameters
- isSolid Boolean
- Indicates if the Form is Solid or Void.
- singleSurfaceForm Form
- The single-surface form element. It can have one top/bottom face or one side face.
- thickenDir XYZ
- The offset of capped solid.
Return Value
FormThis function will modify the input singleSurfaceForm and return the same element.