GetElement Method (Reference)


Gets the Element referenced by the input reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public Element GetElement(
	Reference reference
)
Visual Basic
Public Function GetElement ( _
	reference As Reference _
) As Element
Visual C++
public:
Element^ GetElement(
	Reference^ reference
)

Parameters

reference
Type: Autodesk.Revit.DBReference
The reference, whose referenced Element will be retrieved from the model.

Return Value

The element referenced by the input argument.

Remarks

a null reference (Nothing in Visual Basic) will be returned if the input reference doesn't reference to a valid Element.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also