GetElement Method (Reference)


Document Get Element(Reference) Method

Gets the Element referenced by the input reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Element GetElement(
	Reference reference
)

Parameters

reference Reference
The reference, whose referenced Element will be retrieved from the model.

Return Value

Element
The element referenced by the input argument.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
will be returned if the input reference doesn't reference to a valid Element.
See Also