CreateFaceGeometryInfo Method (Double, Boolean)


Creates a new container object which holds IfcFace handles processed from a Revit geometry object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public static IFCGeometryInfo CreateFaceGeometryInfo(
	double epsilon,
	bool isCoarse
)
Visual Basic
Public Shared Function CreateFaceGeometryInfo ( _
	epsilon As Double, _
	isCoarse As Boolean _
) As IFCGeometryInfo
Visual C++
public:
static IFCGeometryInfo^ CreateFaceGeometryInfo(
	double epsilon, 
	bool isCoarse
)

Parameters

epsilon
Type: SystemDouble
The epsilon value used to process surfaces.
isCoarse
Type: SystemBoolean
Indicates whether we should use a coarse representation.

Return Value

The new geometry info container.

See Also