GetFaceRegions Method


Gets the FaceRegions in the existing face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public static IList<Reference> GetFaceRegions(
	Document cda,
	Reference referenceOfFace
)
Visual Basic
Public Shared Function GetFaceRegions ( _
	cda As Document, _
	referenceOfFace As Reference _
) As IList(Of Reference)
Visual C++
public:
static IList<Reference^>^ GetFaceRegions(
	Document^ cda, 
	Reference^ referenceOfFace
)

Parameters

cda
Type: Autodesk.Revit.DBDocument
The Document.
referenceOfFace
Type: Autodesk.Revit.DBReference
The Reference of the existing face.

Return Value

The FaceRegions in the existing face, or an empty collection if no FaceRegions are found.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The Reference is not a Face Reference.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also