GetFaceRegions Method


Curve By Points Utils Get Face Regions Method

Gets the FaceRegions in the existing face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static IList<Reference> GetFaceRegions(
	Document cda,
	Reference referenceOfFace
)

Parameters

cda Document
The Document.
referenceOfFace Reference
The Reference of the existing face.

Return Value

IList Reference
The FaceRegions in the existing face, or an empty collection if no FaceRegions are found.
Exceptions
Exception Condition
ArgumentException The Reference is not a Face Reference.
ArgumentNullException A non-optional argument was null
See Also