SetCategories Method


Sets the rule's categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public bool SetCategories(
	ICollection<ElementId> categories
)
Visual Basic
Public Function SetCategories ( _
	categories As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
bool SetCategories(
	ICollection<ElementId^>^ categories
)

Parameters

categories
Type: System.Collections.GenericICollectionElementId
The categories.

Return Value

True if the set of categories was changed, false if no change was necessary.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException One of the given categories is not filterable
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also