SetCategories Method


Filter Category Rule Set Categories Method

Sets the rule's categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool SetCategories(
	ICollection<ElementId> categories
)

Parameters

categories ICollection ElementId
The categories.

Return Value

Boolean
True if the set of categories was changed, false if no change was necessary.
Exceptions
Exception Condition
ArgumentException One of the given categories is not filterable
ArgumentNullException A non-optional argument was null
See Also